PHP中16个高危函数

php中内置了许许多多的函数,在它们的帮助下可以使我们更加快速的进行开发和维护,但是这个函数中依然有许多的函数伴有高风险的,比如说一下的16个函数不到万不得已不尽量不要使用,因为许多“高手”可以通过这些函数抓取你的漏洞。

1、passthru()

功能描述:允许执行一个外部程序并回显输出,类似于 exec()。

危险等级:高

2、exec()

功能描述:允许执行一个外部程序(如 UNIX Shell 或 CMD 命令等)。

危险等级:高

3、system()

功能描述:允许执行一个外部程序并回显输出,类似于 passthru()。

危险等级:高

4、chroot()

功能描述:可改变当前 PHP 进程的工作根目录,仅当系统支持 CLI 模式

PHP 时才能工作,且该函数不适用于 Windows 系统。

危险等级:高

5、chgrp()

功能描述:改变文件或目录所属的用户组。

危险等级:高

6、chown()

功能描述:改变文件或目录的所有者。

危险等级:高

7、shell_exec()

功能描述:通过 Shell 执行命令,并将执行结果作为字符串返回。

危险等级:高

8、proc_open()

功能描述:执行一个命令并打开文件指针用于读取以及写入。

危险等级:高

9、proc_get_status()

功能描述:获取使用 proc_open() 所打开进程的信息。

危险等级:高

10、ini_alter()

功能描述:是 ini_set() 函数的一个别名函数,功能与 ini_set() 相同。

具体参见 ini_set()。

危险等级:高

11、ini_set()

功能描述:可用于修改、设置 PHP 环境配置参数。

危险等级:高

12、ini_restore()

功能描述:可用于恢复 PHP 环境配置参数到其初始值。

危险等级:高

13、dl()

功能描述:在 PHP 进行运行过程当中(而非启动时)加载一个 PHP 外部模块。

危险等级:高

14、pfsockopen()

功能描述:建立一个 Internet 或 UNIX 域的 socket 持久连接。

危险等级:高

15、popen()

功能描述:可通过 popen() 的参数传递一条命令,并对 popen() 所打开的文件进行执行。

危险等级:高

16、putenv()

功能描述:用于在 PHP 运行时改变系统字符集环境。在低于 5.2.6 版本的 PHP 中,可利用该函数

修改系统字符集环境后,利用 sendmail 指令发送特殊参数执行系统 SHELL 命令。

危险等级:高

以上就是PHP中16个高危函数的详细内容,更多请关注求知技术网其它相关文章!

发表评论

电子邮件地址不会被公开。 必填项已用*标注